HyperMesh 8.0 Tutorials
Basics
Altair Engineering Contact Information

Web site  www.altair.com

Login: ftp
Password: <your e-mail address>

<table>
<thead>
<tr>
<th>Location</th>
<th>Telephone</th>
<th>e-mail</th>
</tr>
</thead>
<tbody>
<tr>
<td>North America</td>
<td>248.614.2425</td>
<td><a href="mailto:hwsupport@altair.com">hwsupport@altair.com</a></td>
</tr>
<tr>
<td>China</td>
<td>86.21.5393.0011</td>
<td><a href="mailto:support@altair.com.cn">support@altair.com.cn</a></td>
</tr>
<tr>
<td>France</td>
<td>33.1.4133.0990</td>
<td><a href="mailto:francesupport@altair.com">francesupport@altair.com</a></td>
</tr>
<tr>
<td>Germany</td>
<td>49.7031.6208.22</td>
<td><a href="mailto:hwsupport@altair.de">hwsupport@altair.de</a></td>
</tr>
<tr>
<td>India</td>
<td>91.80.6629.4500</td>
<td><a href="mailto:support@india.altair.com">support@india.altair.com</a></td>
</tr>
<tr>
<td></td>
<td>1.800.425.0234 (toll free)</td>
<td></td>
</tr>
<tr>
<td>Italy</td>
<td>39.800.905.595</td>
<td><a href="mailto:support@altairtorino.it">support@altairtorino.it</a></td>
</tr>
<tr>
<td>Japan</td>
<td>81.3.5396.1341</td>
<td><a href="mailto:support@altairjp.co.jp">support@altairjp.co.jp</a></td>
</tr>
<tr>
<td></td>
<td>81.3.5396.2881</td>
<td></td>
</tr>
<tr>
<td>Korea</td>
<td>82.31.716.4321</td>
<td><a href="mailto:support@altair.co.kr">support@altair.co.kr</a></td>
</tr>
<tr>
<td>Scandinavia</td>
<td>46.46.286.2052</td>
<td><a href="mailto:support@altair.se">support@altair.se</a></td>
</tr>
<tr>
<td>United Kingdom</td>
<td>44.1926.468.600</td>
<td><a href="mailto:support@uk.altair.com">support@uk.altair.com</a></td>
</tr>
<tr>
<td>Brazil</td>
<td>55.11.4223.5733</td>
<td><a href="mailto:br_support@altair.com">br_support@altair.com</a></td>
</tr>
<tr>
<td>Australia</td>
<td>64.9.413.7981</td>
<td><a href="mailto:anzsupport@altair.com">anzsupport@altair.com</a></td>
</tr>
<tr>
<td>New Zealand</td>
<td>64.9.413.7981</td>
<td><a href="mailto:anzsupport@altair.com">anzsupport@altair.com</a></td>
</tr>
</tbody>
</table>

The following countries have distributors for Altair Engineering: Mexico, Romania, Russia, South Korea, Singapore, Spain, Taiwan and Turkey. See www.altair.com for complete contact information.

© 2007 Altair Engineering, Inc. All rights reserved. No part of this publication may be reproduced, transmitted, transcribed, stored in a retrieval system, or translated to another language without the written permission of Altair Engineering, Inc. To obtain this permission, write to the attention Altair Engineering legal department at: 1820 E. Big Beaver, Troy, Michigan, USA, or call +1-248-614-2400.

Trademark and Registered Trademark Acknowledgments
Listed below are Altair® HyperWorks® applications. Copyright® Altair Engineering Inc., All Rights Reserved for:


All other trademarks and registered trademarks are the property of their respective owners.
HyperMesh 8.0 Tutorials
Basics

Getting Started with HyperMesh - HM-1000 ................................................................. 1
Opening and Saving Files - HM-1010 ............................................................................. 4
Working with Panels - HM-1020 .................................................................................. 11
Organizing a Model - HM-1030 .................................................................................. 18
Controlling the Display - HM-1040 ............................................................................. 28
Getting Started with HyperMesh - HM-1000

In this tutorial, you will explore the basic concepts of the user interface of HyperMesh 8.0.

Overview

It is highly recommended before you begin the exercise, you review the general overview for this tutorial.

Tools

The HyperMesh interface contains several areas. Each is described below.

<table>
<thead>
<tr>
<th>Area</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title bar</td>
<td>The bar across the top of the interface is the Title bar. It contains the version of HyperMesh that you are running and the name of the file you are working on.</td>
</tr>
<tr>
<td>Graphics area</td>
<td>The Graphics area under the title bar is the display area for your model. You can interact with the model in three-dimensional space, in real time. In addition to viewing the model, entities can be selected interactively from the Graphics area.</td>
</tr>
<tr>
<td>Pull down menu</td>
<td>Located just under the title bar. Like the pull-down menus in many graphical user interface applications, these menus “drop down” a list of options when clicked. Use these options to access different areas of HyperMesh functionality.</td>
</tr>
<tr>
<td>Toolbar</td>
<td>Located just under the graphics area, these buttons provide quick access to commonly-used functions, such as changing display options.</td>
</tr>
<tr>
<td>Command Window</td>
<td>You can type HyperMesh commands directly into this text box and execute them instead of using the HyperMesh Graphical User Interface.</td>
</tr>
</tbody>
</table>
Macro menu

This area contains five pages of macros that perform various functions. The Disp macro page is active and is shaded to signify this. The Disp page macros control how a model displays in the Graphics area.

The other macro pages available are QA (contains element checking macros), Mesh (contains macros associated with creating and editing meshes), User (contains macros you create), and Geom (contains macros related to working with a model's geometry).

The content of the macro menu changes based upon the selected user profile.

Header bar

The Header bar separates the Graphics area from the Panel area. The left end of the Header bar displays your current location. At this time, you will see Geometry displayed. The three fields on the right side of the header bar display the active user profile, current component collector and current load collector. The latter two fields are blank.

As you work in HyperMesh, any warning or error messages also display in the Header bar. Warning messages appear in green and error messages appear in red.

The quit button on the rightmost end of the Header bar ends the HyperMesh session. When you select quit, if changes have not been saved a save file information confirmation message appears so you can save your changes before HyperMesh closes down.

Hint You can hold the left mouse button down on top of a panel to see a description for it in the Header bar.

Page menu

The Page menu allows you to select different sets of functions.

The Geom page contains functions having to do with the creation and editing of geometry.

The 1D, 2D, and 3D pages contain element creation and editing tools grouped according to element type.

The Analysis page contains functions to set up the analysis problem and define the boundary conditions.

The Tool page contains miscellaneous tools and model checking functions.

The Post page contains post-processing functions.

Panel menu

The Panel menu displays for each page the functions available on that page. You access those functions by clicking on the button corresponding to the function you wish to use.

Process

To start HyperMesh on a PC, go to Start > Programs > Altair HyperWorks > Altair HyperMesh.
Strategy

By default, HyperMesh uses the "start directory" for files.

To determine the start directory on Windows, perform the following steps:
1. Right click the HyperMesh icon.
2. Go to Properties.
3. On the Shortcut tab, view the path in the Start In field.

On UNIX, the start directory is determined by the following:
- Location you typed the command to run HyperMesh
- Your "home" directory if configuration files are not found in the start directory

To obtain help for a particular feature, go to the Help menu and select HyperMesh, OptiStruct and Batch Mesher. If accessed while on the main menu, help will open the contents. If accessed while in a panel, help will open directly to the help for that panel. The help contains the following types of information:
- How to use individual functions
- Notes on interfacing HyperMesh with external data types
- Tutorials
- Programming guides
- Organized by product

Model Files

All files referenced in the HyperMesh tutorials are located in the <install_directory>/tutorials/hm/ directory unless otherwise noted. For detailed instructions on how to locate the installation directory <install_directory> at your site, see Finding the Installation Directory <install_directory>, or contact your system administrator.
Opening and Saving Files - HM-1010

In this tutorial, you will learn how to:

- Open a HyperMesh file
- Import a file into a current HyperMesh session
- Save the HyperMesh session as a HyperMesh model file
- Export all the geometry to an IGES file
- Export all the mesh data to an OptiStruct input file
- Delete all data from the current HyperMesh session
- Import an IGES file
- Import an OptiStruct file to the current HyperMesh session

Tools

The **files** panel will be used in this tutorial. It can be accessed by one of two methods:

- From the toolbar, click the **files** icon
- Go to the **File** menu

**Files** panel

The files panel allows you to read and write data into and from HyperMesh. It contains the following sub-panels:

<table>
<thead>
<tr>
<th>Sub-panel</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>hm file</td>
<td>Save and retrieve HyperMesh binary databases</td>
</tr>
<tr>
<td>import</td>
<td>Import CAD-generated geometry or finite element model information</td>
</tr>
<tr>
<td></td>
<td>Import multiple HyperMesh databases</td>
</tr>
<tr>
<td></td>
<td>Append models to existing display</td>
</tr>
<tr>
<td></td>
<td>Import connector files (.mcf)</td>
</tr>
<tr>
<td>export</td>
<td>Export CAD geometry or finite element information for specific analysis codes</td>
</tr>
<tr>
<td>command</td>
<td>Run a HyperMesh command file</td>
</tr>
<tr>
<td>template</td>
<td>Specify a solver template file</td>
</tr>
<tr>
<td>results</td>
<td>Specify a results file</td>
</tr>
</tbody>
</table>
Exercise 1: Exploring the Files Panel

This exercise uses the model files: `bumper_cen_mid1.hm`, `bumper_mid.hm`, `bumper_end.igs`, and `bumper_end_rgd.fem`. Each model file contains various sections, but the whole bumper model is shown below.

Step 1: Open the HyperMesh model file, `bumper_cen_mid1.hm`.

1. Access the open feature in one of the following ways:
   - On the File menu, click Open
   - Click the file icon and click retrieve
2. Open the model file, `bumper_cen_mid1.hm`.
   The model file, `bumper_cen_mid1.hm`, is now loaded. This file contains mesh and geometry data.
3. Go to the Files panel, if necessary.

![HyperMesh model file, bumper_cen_mid1.hm, opened in HyperMesh](image)

Step 2: Import the HyperMesh model file, `bumper_mid.hm`, into the current HyperMesh session.

1. To access the import feature, do one of the following:
   - On the File menu, point to Import, and click HyperMesh Model
   - Click the file icon, go to the import sub-panel, and click HM MODEL
2. Open the file, `bumper_mid.hm`.

![HyperMesh model file, bumper_mid.hm, opened in HyperMesh](image)
3. Remain in the **Files** panel. Or, go the **File** menu (if necessary).

HyperMesh model file, *bumper_mid.hm*, imported on top of existing data in the HyperMesh session

**Step 3: Import the IGES geometry file, bumper_end.igs, into the current HyperMesh session.**

1. Access the **import** feature in one of the following ways:
   - On the **File** menu, point to **Import**, point to **Geometry**, and click **Iges**
   - Click the file icon 📝, go to the **import** sub-panel, select **GEOM**, and toggle to **IGES**
2. Browse to the file, `bumper_end.igs`.

Geometry data is added to the model.

3. Remain in the **import** subpanel.

**Step 4: Import the OptiStruct input file, `bumper_end_rgd.fem`, into the current HyperMesh session.**

1. Click **FE**.

2. Click the switch ▼ and select **OPTISTRUCT**, if necessary.

   **Note** A list of the various solver input file formats supported by HyperMesh appears. OptiStruct is a finite element based structural analysis and optimization solver. HyperMesh sets the filter on the file browser to search for .fem or .parm files.

3. Import the file, `bumper_end_rgd.fem`. 
4. Remain in the **Files** panel. Or, go the **File** menu (if necessary).

**Note** This OptiStruct input file contains mesh for the bumper’s end portion. The mesh is added to the existing data in the current HyperMesh session and will be located in the same area as the geometry representing the bumper’s end.

OptiStruct input file, `bumper_end_rgd.fem`, imported on top of data in the current HyperMesh session

**Step 5: Save the HyperMesh session as a HyperMesh model file called `practice.hm`**.

Access the **save** feature in one of the following ways:

- On the **File** menu, click **SaveAs**
- Click the file icon on the toolbar, go to the **hm** sub-panel, and click **save as...**

**Note**: The data currently loaded in HyperMesh is now saved in a HyperMesh binary data file of the name you entered.

Remain in the **Files** panel. Or, go the **File** menu (if necessary).

**Note**: **Save** (without three dots) saves the HyperMesh session to the file name specified in the **file**: field. **Save as...** (with three dots) opens a file browser and prompts you for a file name to which to save the HyperMesh session.
Step 6: Export the model’s geometry data to an IGES file called practice.igs.

Access the export feature in one of the following ways:
- On the File menu, point to Export, and click IGES Geometry
- Click the file icon, go to the export sub-panel, click iges, and then click write as...

Remain in the Files panel.

Step 7: Export the model’s mesh data to an OptiStruct input file called practice.fem.

1. On the Preferences menu, click User Profiles.
2. Select OptiStruct.
   The OptiStruct template contains OptiStruct specific formatting instructions that HyperMesh uses to create an OptiStruct input file.
3. On the toolbar, Click the file icon.
4. Go to the export sub-panel.
5. Click template.
6. Click write as… and browse to the file, practice.fem.
7. Click return to go to the main menu.

Step 8 (Optional): Delete all data from the current HyperMesh session.

1. Access the delete feature in one of the following ways:
   - Press F2 on the keyboard
   - On the Tool page, go to the delete panel
2. Click delete model.
3. Answer Yes to the pop-up question "Do you wish to delete the current model? (y/n)?
4. Click return to go to the main menu.

Step 9 (Optional): Import the IGES geometry file you created, practice.igs.

Refer to Step 3 for detailed instructions.
Step 10 (Optional): Import the Optistruct input file you created, practice.fem, into the current HyperMesh session.

Import practice.fem into the current session. The data in the file will be added to the existing data in the current HyperMesh session. Refer to Step 4 for detailed instructions.

With the completion of Steps 8, 9, and 10, your current HyperMesh session should contain all of the geometry and mesh data that existed in the HyperMesh session that was saved to a HyperMesh file in Step 5.

Step 11 (Optional): Save your work.
Working with Panels - HM-1020

A large portion of HyperMesh functionality is organized into panels. Many panels have common attributes and controls, so once you become familiar with the features of one panel, it is much easier to understand other panels.

In this tutorial, you will learn how to:

- Use the entity selector and the extended entity selection menu to select and unselect nodes and elements from the graphics area.
- Use the direction selector to define vectors along which to translate nodes and elements.
- Switch between different entities to select, and methods to define vectors.
- Toggle between two options.
- Enter, copy and paste, and calculate numbers.
- Use the rapid menu functionality to execute commands with the mouse buttons rather than clicking buttons.
- Interrupt, but not exit, a panel to go to another panel using the keyboard function keys.

Overview

It is highly recommended before you begin the exercise, you review the general overview for this tutorial.

Exercise

Step 1: Retrieve the HyperMesh model file, bumper.hm.

1. Access the File panel in one of the following ways:
   - On the File menu, click Open
   - On the toolbar, click the file icon and go to the hm file sub-panel
2. Click retrieve... and browse to <install directory>/tutorials/hm/bumper.hm.
3. Click Open.

Step 2: In the translate panel, select nodes from the graphics area.

1. Access the translate panel in one of the following way:
   - On the Tools menu, click Translate
   - On the Tool page, click translate
2. With the **nodes** selector active, select a few nodes from the graphics area by left clicking on the corners of the elements.

![Node selector](image)

Node selector

The cyan border around it indicates that it is active; HyperMesh is expecting nodes to be selected as the next action.

A node is positioned at each element corner. Selected nodes are highlighted with a small, white circle.

**Node Handles**

![Node handles](image)

3. **Reset** the selection of nodes by clicking the reset icon, ![Reset icon](image).

**Step 3: Select and unselect elements from the graphics area.**

1. Click the entity selector switch ![Entity selector switch](image) and select elems. (Switch the entity selector to elems.)

![Entity selector](image)

Entity selector with its switch

The menu that pops-up contains a list of entities that can be translated.
2. With the elems selector active, select several elements from the graphics area. 
   **Note:** To select an element, click on its element handle or the dot at the element’s center. The elements are highlighted in white when they are selected.

3. Unselect an element by selecting it with the right mouse button.

**Step 4: Select and unselect elements using the quick window selection method.**

1. Verify that the *elems* selector is active.
2. Move the mouse handle into the graphics area.
3. Press and hold the Shift key + left mouse button and move the mouse to draw a rectangular window around a few elements, and then release the Shift key and left mouse button. All the element handles inside the rectangular window are selected.
4. Unselect elements by pressing and holding the Shift key + right mouse button and moving the mouse to create a window around the selected elements.
5. Press the Shift key and quick click the left mouse button.
   A pop-up window appears, which contains four icons as shown in the image below.

![Quick window pop-up menu](image)

6. Select the inside polygon shape.
7. Press and hold the Shift key + left mouse button and move the mouse around a few unselected elements, and then release the Shift key and mouse button.
   You drew a polygon window rather than a rectangular window. All element handles inside this window were selected.

**Step 5: Select and unselect elements by using the extended entity selection menu.**

1. Click the `elems` selector and select `reverse`. (Select `elems >> reverse`.)
   The selection of elements is reversed; the elements that were selected are now unselected and the elements that were not selected are now selected.

   The menu that appears contains a list of functions for selecting elements. Once you select a function from the menu, the menu disappears. If you do not want to select a function, move the mouse handle out of the menu.

   ![Extended entity selection menu](image)

2. Select `elems >> by adjacent`.
   Elements adjacent to the selected elements are now selected.

**Step 6: Shade the elements, reset the selection, and select a few adjacent elements.**

1. On the toolbar, click the `Shaded Elements & Mesh Lines` icon.
   The elements are displayed in shaded mode, rather than wireframe mode.

2. In the `translate` panel, click the `reset` icon to clear the elements selection.
3. With the `elems` selector active, select a few elements that are adjacent to each other.
Step 7: Specify a direction vector (N1 and N2 only) along which to translate the selected elements.

1. Click the direction selector switch.

   ![Direction selector pop-up menu]

   Direction selector along with the node selectors to define the direction vector.

   The menu shown below appears. It contains a list of vector and plane options for defining the direction in which to translate the selected elements.

   - x-axis
   - y-axis
   - z-axis
   - vector
   - N1, N2, N3

   Direction selector pop-up menu.

2. Select N1, N2, N3 from the pop-up menu.

   N1 now has a cyan border indicating it is the active selector.

   The selected elements are displayed in gray because the elems entity selector is not active.

3. In the graphics area, select any node for N1.

   The selected node is highlighted in green. The active selector advances to N2.

4. Select a node near N1 for N2.

   The selected node is highlighted in blue. The active selector advances to N3. Do not select a node for N3.

   **Note:** Selecting the two nodes, N1 and N2, defines a vector for the direction of translation. This vector goes from N1 towards N2.

   Selecting a third node, N3, defines a plane. The direction of translation is the positive direction of the vector normal to the plane. The positive direction is determined by the right-hand rule.

Step 8: Specify a distance to translate the selected elements and then translate them.

1. Click the toggle to change magnitude = to magnitude = N2-N1.

2. Click translate +.

   The selected elements translate in the direction from N1 to N2 by N2-N1 units.

3. Notice the thick, black border around the translate button. It indicates this is a rapid menu button; you can click the middle mouse button rather than click translate +.
4. Click the middle mouse button.
   The selected elements are translated again by N2-N1 units.

5. Click **translate** - twice.
   The selected elements are translated in the negative N1-N2 vector direction and are now in their original position.

**Step 9: Measure the distance between two nodes.**

1. Press the F4 function key to interrupt, but not exit, the translate panel and go to the distance panel on the Geom page.
   The element and node you selected in the translate panel are currently not visible. However, they are still selected. They will be visible again when you return to the translate panel.

2. Verify you are in the two nodes sub-panel.
   Notice N1 is the active selector.

3. Select any node for N1.
   The entity selector advances to N2.

4. Select a node near N1 for N2.
   Notice the distance = field value reflects the absolute distance between N1 and N2.

5. Click in the distance = field to highlight the value.

6. Press Ctrl + C to copy the value.

7. Return to the translate panel.

8. Notice the elements and nodes you selected in the translate panel before you went to the distance panel are once again visible.

**Step 10: Specify a distance to translate the selected elements and then translate them.**

1. Toggle from magnitude = N1-N2 to magnitude =.

2. Click in the **magnitude** = field to highlight its value.

3. Press Ctrl + V to paste the **distance** = value copied from the distance panel.

4. Click translate +.
   The selected elements translate in the direction from **N1** to **N2** by the number of units specified for **magnitude** =.

5. Click **translate** – once.
   The selected elements are translated in the negative N1-N2 vector direction and are now in their original position.
**Step 11:** Calculate $5.5 \times 10.5$ and specify the resulting value for $\text{magnitude} =$.

1. Double-click $\text{magnitude} =$.
2. Click $5.5$ (in that order) and then click $\text{enter}$.
3. Click $10.5$ (in that order).
4. Click $X$.
   
   The calculated value in the calculator window is 57.75.
5. Click $\text{exit}$.
   
   The calculator closes and 57.75 appears in the $\text{magnitude} =$ field.

   You can type a value in the $\text{magnitude} =$ field by clicking in the field once to highlight the current value. Then type a new value.

**Step 12:** Specify a new vector and translate the elements again.

1. Click the $\text{reset}$ icon $\text{[icon]}$.
2. Notice $N1$ is the active selector.
3. Select three nodes for $N1$, $N2$, $N3$ to define a plane.
4. Click $\text{translate} +$ or press the middle mouse button.
   
   The elements are translated 57.75 units in the positive direction normal to the defined plane.
5. $\text{Return}$ to the main menu.

**Step 13 (Optional):** Save your work.

With all of the exercise complete, you can save the model if desired.
Organizing a Model - HM-1030

A large portion of HyperMesh functionality is organized into panels. Many panels have common attributes and controls, so once you become familiar with the features of one panel, it is much easier to understand other panels.

In this tutorial, you will learn how to:

- Create geometry and organize it into components.
- Organize elements into the components.
- Rename components.
- Identify and delete empty components.
- Delete all the geometry lines.
- Reorder the components in a specific order.
- Renumber all the components, starting with ID 1 and incrementing by 1.
- Create an assembly.
- Organize the constraints.

Overview

It is recommended to review the general overview before completing this tutorial.

Step 1: Retrieve the model file, `bumper.hm`.

![Diagram of a model with constraints and loads]
Step 2: Create a component named \textit{geometry}, to hold the model's geometry.

1. Access the \textit{collectors} panel in one of the following ways:
   - On the \textit{Organize} menu, click \textit{Collectors}
   - On the toolbar, click the collectors icon
2. Go to the \textit{create} sub-panel.
3. Use the drop down arrow to select \textit{components}.
4. For \textit{name} specify \textit{geometry}.
5. Select \textit{color} >> yellow.
6. Leave the \textit{card image} field blank.
7. Leave the \textit{material} field blank.
8. \textit{Create} the component collector \textit{geometry}.

   The message: "The collector was created", appears in the header bar.

   Left click once anywhere in the HyperMesh window, except on a button to dismiss the message in the header bar.

   \textit{comp: geometry} appears in the header bar. The component \textit{geometry} is now the current component. Any geometry or elements that are created will be organized into this component.

9. \textit{Return} to the main menu.

Step 3: Create two geometry lines and organize them into different components.

1. Access the \textit{lines} panel in one of the following ways:
   - On the \textit{Geometry} menu, slide the cursor to \textit{Lines} and click \textit{Create}.
   - On the \textit{Geom} page, enter the \textit{lines} panel.
2. Go to the \textit{from nodes} sub-panel.
3. With the **node list** selector active, select two nodes, opposite and diagonal to each other, on the same element as indicated in the image below.

![Select two opposite and diagonal nodes of an element](image)

4. **Create** the line.

5. Notice the line is yellow, the same color assigned to the component, **geometry**. This is because the line is organized into the current component, **geometry**.

6. On the toolbar, click on **comp** to view current collectors.

7. Notice in the collector’s pop-up current **comp** shows **geometry**.

8. Click **comp** and select the component, **rigid**, from the list of components in the model.

9. The panel now shows **comp: rigid**. Also, the header bar shows **comp: rigid**.

10. Moving the cursor away from the collector’s popup will return you to the **lines** panel.

11. **Create** the line.

12. With the **node list** selector active, select two nodes, opposite and diagonal to each other on another element.

13. Notice the line is dark pink, the same color assigned to the component, **rigid**. This is because the line is organized into the current component, **rigid**.

14. **Return** to the main menu.
Step 4: Move all the model’s geometry surfaces into the component, geometry.
1. Access the organize panel in one of the following ways:
   - On the Organize menu, click Entities.
   - On the Tool page, go to the organize panel.
2. Switch the entity selector to surfs.
3. Select surfs >> all.
4. Displayed surfaces are highlighted in white indicating they are selected. All other surfaces that are not displayed are still selected because you selected surfs >> all.
5. Click destination = and select the component, geometry, from the list of components in the model.
6. Select geometry from the list.
7. Move the selected surfaces into the component, geometry.

Step 5: Move all the model’s shell elements (quads and trias) into the component, center.
You should still be in the organize panel.
1. Switch the entity selector to elems.
2. Select elems >> by collector.
   A list of the model’s components appears.
3. Select the components, mid1, mid2, and end.
   Select a component by left clicking its name, color, or check box. A component is selected when it has a check in its check box. To unselect a component, right click on it.
4. Click select to complete the selection of components.
5. Set dest = to the component, center.
6. Move the elements in the selected components to the component, center.
   All of the shell elements should now be a cyan blue, the same color assigned to the component, center.
7. Return to the main menu.

Step 6: Rename the component, center to shells.
1. Access the rename panel in one of the following ways:
   - From the Organize menu, click Rename
   - On the Tool page, go to the rename panel.
2. Go to the individually sub-panel.
3. Verify the entity type is set to comps.
4. Click original name = and select the component, center, from the list of the model’s components.
5. Click once in the new name = field to highlight its text.
6. Type shells.
7. Rename the component.
8. Return to the main menu.

Step 7: Identify and delete all of the empty components.
1. Access the delete panel in one of the following ways:
   • From the Edit menu, click Delete
   • On the Tool page, go to the delete panel.
2. Switch the entity selector to comps.
3. Click preview empty.
   The header bar displays the message: “3 entities are empty.”
   These are the mid1, mid2, and end components that no longer have elements in them.
4. Click the entity selector comps once to see a list of the identified empty components.
   A complete list of the model’s components appears. The empty components are indicated with an activated check box.
5. Return to the delete panel.
6. Click delete entity.
   The header bar displays the message, “Deleted 3 comps”.

Step 8: Delete all the geometry lines in the model.
You should still be in the delete panel.
1. Switch the entity selector to lines.
2. Select lines >> all.
3. Click delete entity.
   The two lines you created earlier are deleted.
4. Return to the main menu.

Step 9: Move the component, geometry, to the front in the components list.
1. Access the reorder panel in one of the following ways:
   • From the Organize menu, click Reorder
   • On the Tool page, go to the reorder panel
2. Click the comps selector to see a list of the model’s components.
3. On the right side of the panel, click the switch and select name(id). (Switch from name to name(id).)
4. Notice the IDs of the components. The ID for shells is one, the ID for rigid is five, and the ID for geometry is six.
5. Select the component, geometry.
6. Click select to complete the selection.
7. Activate the option move to: front.
8. Reorder the component, geometry.
9. The header bar displays the message, "The selected collectors have been moved."
10. Click the comps selector once to review the reordered list of components.
11. Notice the component, geometry, is at the top of the list. However, it still has the same ID, six.
12. Return to the main menu.

Step 10: Renumber the components to be the same as their position in the list.
1. Access the renumber panel in one of the following ways:
   • From the Organize menu, click Renumber
   • On the Tool page, go to the renumber panel
2. Go to the single sub-panel.
3. Switch the entity selector to comps.
4. Click the comps selector to see a list of the model’s components.
5. On the panel’s right side, select comps >> all.
6. Click select to complete the selection of components.
7. Verify start with = is set to 1.
8. Verify increment by = is set to 1.
9. Verify offset = is set to 0.
10. Renumber the components.
11. Click the comps selector to review the model’s component list.
12. Notice the components are numbered according to their position in the list.
13. Return to the main menu.

Having components with IDs that do not reflect their position in the model’s list of components will not result in errors. However, having components with IDs that do reflect their position in the model’s list of components can be helpful for organizational purposes.

Step 11: Create an assembly containing the components, shells and rigid.
1. The assemblies panel can be accessed in one of the following ways:
   • From the Organize menu, click Assemblies
   • On the Tool page, enter the assemblies panel
2. Go to the create sub-panel.
3. For name = specify elements.
4. Click the comps selector to see a list of the model’s components.
5. Select the components shells and rigid.
6. Click select to complete the selection of components.
7. Create the assembly.
8. Return to the main menu.

**Step 12: Create a load collector named constraints.**

1. Access the collectors panel in one of the following ways:
   - On the Organize menu, click Collectors
   - On the toolbar, click the collectors icon
2. Go to the create sub-panel.
3. Use the drop down arrow to select load collectors.
4. For name = specify constraints.
5. Select color >> red.
6. Leave the card image = field blank.
7. Create the load collector.
   The header bar displays the message: “The collector was created”.
8. Left click anywhere in the HyperMesh window (except on a button) to dismiss the message in the header bar.
9. Click comp: in the toolbar. Notice that loadcol constraints appears in the popup. Now, the current load collector is constraints. Any loads that are created will be organized into this load collector.
10. Return to the main menu.

**Step 13: Move the model’s one constraint into the load collector, constraints.**

The existing load collector, loads, contains several forces and one constraint. The organize panel is used to move the one constraint in the load collector, constraints.

1. Access the organize panel in one of the following ways:
   - On the Organize menu, click Entities
   - On the Tool page, go to the organize panel.
2. Switch the entity selector to loads.
3. Select loads >> by config.
4. Click config = and select const.
5. Toggle from displayed to all.
6. Click select entities.
7. Verify that destination = is set to the load collector, constraints.
8. Move the select loads (constraints) into the load collector, constraints.
Step 14: Opening the Model Browser.

- Click the Model tab in the macro menu if the macro menu is open. Or go to the View menu, select Model Browser.

Step 15: Create a component from the model browser.

1. Right-click in the white blank area below the list of components, materials, load collectors, and system collectors in the model browser.
2. From the pop-up menu, select **New > Component**.
3. Click on the **color** icon and chose the component's color as pink.
4. Click **Create** to create the component.

The component, named `component1` is appended to the list.

5. In the Model Browser, click the + button beside the Components entity to see that Component1 is bolded in the list to indicate it is the current component.

**Step 16: Review the existing assembly elements from the model browser.**

- Left click the + button next to Assembly Hierarchy then click the + button next to `elements` to expand its tree. Notice that it contains two components, rigid and `shells`.

  Note that the **assemblies** panel allows you to add components, which are in one assembly to another assembly. The model browser does not allow you to do this, but you can create assemblies from it.

**Step 17: Add the components, `geometry` and `component1`, to the assembly, `assem_mid`, using the **Model Browser**.**

1. Left click on the component name, `geometry`, to select it.
2. Press the Ctrl key and left click on the component name, `component1`.

   Press the Ctrl key and left click on a selected item to deselect it.
3. Left click on any one of the selected components and drag the mouse pointer over the assembly, `assem_mid`. When `assem_mid` is highlighted, release the mouse button.

   The selected components are added to the assembly, `assem_mid`.

   Use the Shift key and left mouse button to select multiple items in the model browser list at one time. Left click on the first item in the list. Then press the Shift key and left click on the last item in the list.
Step 18: Rename the assembly, assem_mid to assem_geom, from the Model Browser.
1. Right click on assem_mid and select Rename.
   Assem_mid is highlighted and ready for editing.
2. Type assem_geom and press Enter.

Step 19: Delete component1 from the model browser.
1. Right click on component1 and select Delete.
   Component1 is deleted.
2. Notice that in the list, there is no bolded component name. This indicates there is no current component specified.

Step 20: Set the current component from the model browser.
1. Right click on shells and select Make Current.
   The component name is bolded.
2. Notice that the header bar contains comp: shells
Controlling the Display - HM-1040

When performing finite element modeling and analysis setup, it is important to be able to view the model from different vantage points and control the visibility of entities. You may need to rotate the model to understand the shape, zoom in to view details more closely, or hide specific parts of the model so other parts can be seen. Sometimes a shaded view is best, while other times, a wireframe view allows you work on details inside the model.

HyperMesh has many functions to help you control the view, visibility, and display of entities.

In this tutorial, you will learn how to:

- Control the points of view, mouse, and toolbar.
- Control the visibility of entities using the display panel, mask panel, and tools on the utility menu.
- Control how entities look by using the toolbar, and the model browser.
- Rename components.
- Identify and delete empty components.
- Delete all the geometry lines.

Overview

It is recommended to review the general overview before completing this tutorial.

Step 1: Retrieve the HyperMesh model file, bumper.hm.

Step 2: Manipulate the model view using the mouse controls.

The Ctrl + mouse keys are used to rotate the model, change the center of rotation, zoom, fit, and pan.

1. Move the mouse pointer into the graphics area.
2. Press the Ctrl key + left mouse button and move the mouse around.
   The model rotates with the movement of the mouse.
   A small white square appears in the middle of the graphics area, indicating the center of the rotation.
   Release the left mouse button and press it again to rotate the model in a different direction.
3. Press the Ctrl key and quick click the left mouse button anywhere on the model.
   The center of rotation square appears near where you clicked.
   HyperMesh searches for one of the following conditions in the listed order and relocates the center of rotation at or near the first condition identified. If none of the conditions are met, the center of rotation is relocated to the center of the screen.
   - A nearby node or surface vertex
   - A nearby surface edge to project onto
   - A nearby geometry surface or shaded element
4. Press the Ctrl key + left mouse button to rotate the model and see the change in rotation behavior.
5. Press the Ctrl key and quick click the left mouse button anywhere in the graphics area, except for on the model.
   The center of rotation square is relocated to the center of the screen.
6. Press the Ctrl key + left mouse button to rotate the model and observe the change in rotation behavior.
7. Press the Ctrl key + middle mouse button, move the mouse around, and then release the mouse button.
   A white line is drawn along the path of the mouse movement. When the mouse button is released, HyperMesh zooms in on the portion of the model where the line was drawn.
   You can also simply draw a linear line to zoom in on a portion of the model.
8. Press the Ctrl key + quick click the middle mouse button.
   The model is fitted to the graphics area.
9. Press the Ctrl key and spin the mouse wheel.
   The model zooms in or out depending on which direction you spin the mouse wheel.
10. Move the mouse pointer to a different location in the graphics area and repeat #9.
    Notice the model zooms in or out from where the mouse handle is located.
11. Press the Ctrl key + quick click the middle mouse button to fit the model to the graphics area.
12. Press the Ctrl key + right mouse button and move the mouse around.
    The model is panned (translated) according to the mouse movement.

Step 3: Manipulate the view of the model using the rotate functions on the toolbar.

1. On the toolbar, left click the dynamic rotate / spin icon.
   The header bar displays the message "Move the mouse into the graphics region".
2. Move the mouse pointer into the graphics area.
   The center of rotation square appears.
3. Press and hold the left mouse button, and then move the mouse around.
   The model rotates with the movement of the mouse, similar to the way the model rotates when you press the Ctrl key + left mouse button and move the mouse.
4. Click the middle mouse button on the model.
   The center of rotation square appears near where you clicked.
5. Move the mouse pointer out of the graphics area or right click to exit the rotation mode.
6. On the toolbar, right click on the dynamic rotate / spin icon and move the mouse pointer into the graphics area.
   Again, the center of rotation square appears. You can click the middle mouse button on the model to change the center of rotation.
7. Press the right mouse button near the center of rotation square.
   The model rotates continuously in the direction of your mouse pointer, relative to the center of rotation.

8. With the right mouse button still pressed, move the mouse around slowly.
   The direction and speed of the rotating model changes. The farther the mouse pointer is from the center of rotation, the quicker the model rotates.
   You can release the right mouse button, and then press it again to rotate the model in a different direction.

9. Middle mouse click anywhere in the graphics area, except on the model.
   The center of rotation square is relocated to the screen’s center.

10. Move the mouse pointer out of the graphics area or left click to exit the rotation mode.

**Step 4: Manipulate the view of the model by using the zoom in and out functions on the toolbar.**

1. On the toolbar, left click the *circle / dynamic zoom* icon.
   The header bar displays the message, “Circle the data to be zoomed in on”.

2. Move the mouse pointer into the graphics area.

3. Press the left mouse button, move the mouse around, and then release the left mouse button.
   A white line is drawn along the path of the mouse movement. When the mouse button is released, HyperMesh zooms in on the portion of the model where the line was drawn.
   You can also simply draw a linear line to zoom in on a portion of the model.
   This function is similar to pressing the Ctrl key + middle mouse button to zoom into a portion of the model.

4. On the toolbar, click the *fit* button.
   The model is fitted to the graphics area.

5. On the toolbar, left click the *zoom in / out* icon.
   The model is zoomed in by the factor specified in the *options* panel.

6. On the toolbar, right click the *zoom in / out* icon.
   The model is zoomed out by the same factor.

7. On the *Preferences* menu, click *Options*.

8. Go to the *modeling* sub-panel.


10. Return to the main menu.

11. On the toolbar, left click the *zoom in / out* icon.
    The model is zoomed in by the larger, specified factor.
12. On the toolbar, right click the **circle / dynamic zoom** icon.
   The header bar displays the message "Move the mouse into the graphics region".
13. Move the mouse pointer into the graphics area, press the right mouse button, and then move the mouse pointer up and down.
   The model is zoomed in and out according to how far you move the mouse up or down.
14. Move the mouse pointer out of the graphics area or left click to exit the dynamic zoom mode.

**Step 5: Manipulate the model view using the arrows and view panel on the toolbar.**

1. On the toolbar, right click or left click any of the rotate icons.
   The model rotates in the direction of the arrow by the rotation angle specified in the **options** panel.

2. On the toolbar, left click the **view** icon.
   The **view** panel pops-up.
3. Click **top** to view the model along the Z axis.
4. Exit the **view** panel by moving the mouse pointer out of the pop-up window.
5. On the **Preferences** menu, click **Options**.
6. Go to the **modeling** sub-panel.
7. For **rotate angle** = , specify a value of 90.
8. **Return** to the main menu.
9. Click on either rotate icons.
   Notice the model rotates by the new specified rotation angle, 90.
10. Change the view of the model to any view.
11. Use Ctrl + left mouse button, or the rotate icons on the toolbar to rotate the model.
12. Use Ctrl + middle mouse button, or the zoom icons on the toolbar to zoom into or out on the model.
13. On the toolbar, left click the **view** icon.
14. For **save1** = , enter **my view**.
15. Click **save1** = to save the view.
16. Click **top** to see a different view of the model.
17. Click **restore1** to retrieve the view stored for **save1** =.
   Both the view angle of the model and level of zoom are saved.
18. Exit the **view** panel.
Step 6: Control the display of components using the toolbar.

1. On the toolbar, click the **Shaded Elements & Mesh Lines** icon.
2. Notice the shell element now have been shaded.
3. Right-click the Shaded Elements & Mesh Lines icon to access the Shaded Elements & Feature Lines icon.
4. Notice now the elements shading does not show any mesh lines. Only feature lines are displayed.
5. Right-click the **Shaded Elements & Feature Lines** icon to access the **Shaded Elements** icon.
6. Notice now the feature lines are also removed from the display.
7. Click the **Wireframe Elements (Skin Only)** icon to return to the wireframe shading mode.

Step 7: Control the display of components using the Visual Attributes panel.

1. On the **View** menu, click **FE Styles** to go to the **Visual Attributes** panel.
2. Click the **hidden line** option.
3. Select a component in the list of components.
   The component's elements are displayed in hidden line (shaded) mode.
4. Click **all** to select all components and set their display mode to hidden line (shaded) mode.
5. Experiment with the other display modes.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Display Mode</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Wireframe" /></td>
<td><strong>Wireframe</strong> – Element edges are displayed with lines.</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Hidden Line" /></td>
<td><strong>Hidden Line</strong> – The element is displayed as a filled polygon.</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Hidden Line with Mesh Lines" /></td>
<td><strong>Hidden Line with Mesh Lines</strong> – The element is displayed as a filled polygon with the feature edges drawn in mesh line color.</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Hidden Line with Feature Lines" /></td>
<td><strong>Hidden Line with Feature Lines</strong> – The element as a filled polygon with the feature edges in mesh line color.</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Transparent" /></td>
<td><strong>Transparent</strong> – The element is displayed as a filled transparent polygon.</td>
<td></td>
</tr>
</tbody>
</table>

6. **Return** to the main menu.
Step 8: Control the visibility of various model entities using tools on the Utility menu.

1. On the Disp page of the Utility menu, click Everything: All.
   All the entities in the model will be displayed.
2. Click Elements Only.
   Only elements are displayed, everything else is switched off.
3. Click Loads: On.
   All the loads in the model are added onto the elements already present.

Step 9: Control the visibility of component collectors using the Display panel on the toolbar.

1. On the toolbar, click the Display icon to enter the Display panel.
2. On the panel’s right side, switch the entity type to comps.
3. Toggle the component’s entity type to elems. (It may currently be set to geom.)
4. Clear all check boxes except, center and mid1.
5. The elements in the components, center and mid1, are now displayed.
6. Press f on the keyboard.
   The displayed components are fitted to the graphics area.
7. Toggle elems to geoms.
   In the components list, none of the components are displayed for geometry. A component collector has two ‘compartments’, one for elements and the other for geometry.
8. Activate the components, mid2 and end.
9. Fit the displayed components to the graphics area.
   The geometry in the components, mid2 and end, and the elements in the components, center and mid1, are displayed.
10. Return to the main menu.

Step 10: Control the display of entities using the mask panel.

1. Access the mask panel in one of the following ways:
   - On the Edit menu, click Mask.
   - On the Tool page, enter the mask panel.
2. Go to the mask sub-panel.
3. With the elems selector active, select elems >> by collector.
4. Select the component, mid1.
5. Click **select** to complete the selection of components.

6. From the graphics area, select a few elements in the **center** (blue) component.

7. **Mask** the elements.

   The elements in the **mid1** component and the elements you selected from the graphics area are no longer displayed.

8. On the toolbar, click the Display icon to enter the **Display** panel.

9. Verify the entity type is set to **comps**.

10. Toggle the component’s entity type from **geomsto elems**.

11. Notice that the components, **center** and **mid1**, are still displayed; their check boxes are activated even though some or all of the elements in these components are masked (hidden).

12. **Return** to the **mask** panel.

13. Click **unmask all**.

   All the elements in the components, **center** and **mid1**, are visible again. Notice the elements in the other components are not displayed. This is because these components are not active in the **Display** panel on the toolbar.

14. **Return** to the main menu.

**Step 11: Control the display of entities using the find panel.**

1. Access the find panel in one of the following ways:
   - On the **Edit** menu, click **Find**.
   - On the **Tool** page, enter the **find** panel.

2. Go to the **find entities** sub-panel.

3. Select **elems >> by collector**, and select the component, **end**, from the components list.

4. **Find** the elements.

   The elements in the component, **end**, are displayed.

5. On the toolbar, click the Display icon to enter the **Display** panel.

   Notice that the component, **end**, is now active (displayed). This is because the collector containing the entities that are to be displayed (found) must be active.

6. **Return** to the **find** panel.

7. Go to the **find attached** sub-panel.

8. For **attached to**, select **elems >> displayed**.

9. **Find** the elements.

   Some of the elements in the components, **mid2** and **rigid**, are now displayed. These elements are immediately adjacent and connected to the selected elements.

10. **Return** to the main menu.
11. Enter the mask panel.

12. Click unmask all.

   All of the model’s elements are now displayed. This is because the find panel finds the entities it is supposed to find, activates (displays) the corresponding collectors, and masks the other entities in the collectors it activated. In this case, the last find command displayed on the components, mid2 and rigid, in the disp panel.

13. Return to the main menu.

Step 12: Control the visibility of assemblies using the Display panel.

1. On the toolbar, click the Display icon to enter the Display panel.
2. On the panel’s right side, switch the entity type to ASSEMS.
3. Right-click the assem_mid check box to deactivate (hide) the assembly.
   The assembly, assem_mid, contains the components, mid1 and mid2. The elements in these components are now hidden.
4. Return to the main menu.

Step 13: Customizing the Model Browser.

1. Click the Model tab in the macro menu if the macro menu is open. Or go to the View menu, select Model Browser.
2. Click the Show icon (at the top of the model browser).
   Show is used to filter the entities types displayed on the model browser.
3. Click the down arrow next to Show: All
5. Notice how these items no longer show up in the Model Browser.
6. Click OK at the top of the entity filter dialog.

Step 14: Turn on/off the display of collectors using the Model Browser.

1. Left click the + next to Loadcols to expand its tree.
2. Left click on loads to turn on the display of this load collector.
3. Left click on the components, mid1 and mid2, to turn on their display.
4. At the top of the model browser, click the Geoms icon and deselect the Elems icon by clicking on it.
5. Click the Display None button
   All the displayed geometry is turned off.
Step 15: Change the visualization of components using the *Model Browser*.

1. Right click the visual mode icon next to mid2.
2. From the pop-up select a shading mode.

Observe the change in shading of mid2.
3. Cycle through the shading modes.

Step 16: Change the color of components using the *Model Browser*.

1. Right click the color icon next to mid2.
2. From the color pop-up select a different color.

Observe the change in color of the elements in mid2.